ProductsStoreSupportDownloadsNews

SKY Index Professional v5.1 Tips and Techniques

How Can I double post all entries for a particular main heading?

Create a group of the main heading (Shift+F6)

Select all records in the group (Ctrl+Ins)

Duplicate and Swap all selected entries (Ctrl+P)

How can I create main headings from the subheadings of an existing set of entries?

Create a group of the main heading (Shift+F6)

Select all records in the group (Ctrl+Ins)

Duplicate all selected entries (Ctrl+P)

Shift the Sub1 and all lower heading levels left by one cell (Shift+F1)

How can I create a new set of entries from an existing set changing only the Main heading?

Create a group of the main heading (Shift+F6)

Select all records in the group (Ctrl+Ins)

Duplicate all selected entries (Ctrl+D)

Group the duplicated entries (Shift+F6)

Change the main heading (modify only one of the main headings and press Ctrl+Alt+Enter to propagate the change)

How can I keep track of both subjects and authors in a combined subject/author index?

One way is to configure your index for one more subheading than will appear in the finished index. Use the Main heading to indicate whether the entry is a subject or author entry. For instance, simply enter the letter 's' for subject and 'a' for author.

This will give you two distinct indexes while you work, but will allow you to work with only one index database. If you want to print just the author index, click in the main heading field of any entry that has the main heading 'a'. The group those entries by pressing Shift+F6 or choosing View|Grouped. Next, choose File|Save As. SKY Index will ask if you want to save just the grouped entries. Select Yes. This will create a new index that contains only author entries.

Now get rid of the main heading 'a' by choosing Edit|Select All and then choosing Edit|Shift Left. You will be prompted to specify which heading level to shift left. Choose Sub1. This will shift the Sub1 heading and all lower subheadings left one column and will delete the current main heading. You now have an author index which you can generate and print.

You can print just a subject index in a similar manner.

Hint: You can create a macro that starts a subject entry and another that starts an author entry. Doing so can save you up to two keystrokes per entry.

Is there a way to put my indexes in the My Documents folder?

Yes. What you need to do is modify the program's startup icon to point to the directory of your choice. Here is what to do:

First, decide what directory you want to put your files in and create the directory. My suggestion would be "C:\My Documents\SKY Index".

Click on Start.

Click on Programs.

Right click on the SKY Index Professional icon.

Choose Properties.

Change the "Start In" directory to the directory of your choice using short folder names. For my example you would enter: "C:\My Documents\SKY Index".

Click OK.

Now, copy the file TIPS.INI from your C:\SKYINDEX directory into your new directory.

Finally move your indexes from C:\SKYINDEX directory into your new directory.

I installed SKY Index to my notebook computer and get a "Printer error" message

SKY Index requires that you install a printer driver even if you don't have a printer hooked up to the computer. All you need to do is install a printer driver for any printer. I always recommend an HP LaserJet III, but it does not matter. You do not need to connect a printer to your laptop, you simply need to install at least one printer driver.

Demoting multiple records (This tip was provided by Michael Wyatt)

The problem: Sometimes you will have established a compound heading in the form of a phrase, and then you find you need to split it into a heading plus subheading. How do you do this easily if you have already attached a number of locators to the heading?

The solution: Let's say you have established the heading "goals at work" and attached half a dozen page references. Now you find that "goals" have cropped up in a different context, so you want to change your earlier entries to the heading "goals" with the subheading "at work".

Create a group: Highlight one instance of the heading and create a group by clicking the "Grouped" speedbar button, pressing Shift+F6, or choosing "View > Grouped". (Actually, you can omit this step, but I like to include it so that I can check that what I expect to happen is what actually happens.)

In one of the records insert a comma after "goals".

Propagate the change: Press Control+Alt+Enter, so that all the records read "goals, at work".

Select all the records: If you have grouped them, press Control+Insert or choose Edit > Select All; if you have not grouped them, press Control+Space or choose Edit > Select Record.

Demote: Click the "Demote" speedbar button, press Control+F6, or choose Edit > Demote.

When the "Select field" box pops up, choose "Main" and click OK.

Ungroup the records: If you grouped the records, ungroup them by returning to the view you were working in before.