ProductsStoreSupportDownloadsNews

Tips and Techniques for SKY Index Professional v6.0

Below are some tips and techniques for SKY Index v6.0 owners

My client wants all main headings to have an initial cap. However, there are a few exceptions to this rule. How do I achieve this?

How Can I double post all entries for a particular main heading?

How can I create main headings from the subheadings of an existing set of entries?

How can I create a new set of entries from an existing set changing only the Main heading?

How can I keep track of both subjects and authors in a combined subject/author index?

Demoting multiple records.

How can I duplicate an index entry, swap the main and subheadings, and then combine the subheading with the main heading separated by a space?

My client wants all main headings to have an initial cap. However, there are a few exceptions to this rule. How do I achieve this?

Choose Options | Index Options.

Click the Fonts tab.

Check the Init. Cap option.

Click OK. (All main headings will now have the first letter capitalized automatically regardless of how you type the entry.)

For those entries that you need to override this setting, type a semicolon as the first character. The semicolon will be ignored and the first letter of the heading will not be capitalized.

Back to top

How Can I double post all entries for a particular main heading?

Select all records containing the main heading by choosing Edit | Select Heading (Ctrl+H) while the grid marquee is over the main heading.

Duplicate and Swap all selected entries by choosing Edit | Duplicate & Swap (Ctrl+P)

Back to top

How can I create main headings from the subheadings of an existing set of entries?

With the grid marquee over the desired main heading, duplicate and group the main heading by selecting Edit | Duplicate Heading (Ctrl+F8)

Shift all  subheadings left by one cell by choosing Edit | Shift Left (Ctrl+Alt+F3). You will be asked what heading level to shift left.

Choose Sub1 (the default) and click OK.

Back to top

How can I create a new set of entries from an existing set changing only the Main heading?

With the grid marquee over the desired main heading, duplicate and group the main heading by selecting Edit | Duplicate Heading (Ctrl+F8)

Change the main heading (modify only one of the main headings and press Ctrl+Alt+Enter to propagate the change)

Back to top

How can I keep track of both subjects and authors in a combined subject/author index?

Mark your subject entries using Edit | Mark. You can then use the Filter function to view only the subject entries or only the author entries.

To see only subject entries: Set the Filter dialog so that Unfiltered records are Hidden. Then check the check box to Show marked records.

To see only author entries: Set the Filter dialog so that Unfiltered records are Shown. Then check the check box to Hide marked records.

To see all entries: Click the Clear button on the Filter dialog.

Back to top

Demoting multiple records (This tip was provided by Michael Wyatt)

The problem: Sometimes you will have established a compound heading in the form of a phrase, and then you find you need to split it into a heading plus subheading. How do you do this easily if you have already attached a number of locators to the heading?

The solution: Let's say you have established the heading "goals at work" and attached half a dozen page references. Now you find that "goals" have cropped up in a different context, so you want to change your earlier entries to the heading "goals" with the subheading "at work".

Create a group: Highlight one instance of the heading and create a group by clicking the "Grouped" speedbar button, pressing Shift+F6, or choosing "View > Grouped". (Actually, you can omit this step, but I like to include it so that I can check that what I expect to happen is what actually happens.)

In one of the records insert a comma after "goals".

Propagate the change: Press Control+Alt+Enter, so that all the records read "goals, at work".

Select all the records: If you have grouped them, press Control+Insert or choose Edit > Select All; if you have not grouped them, press Control+Space or choose Edit > Select Record.

Demote: Click the "Demote" speedbar button, press Control+F6, or choose Edit > Demote.

When the "Select field" box pops up, choose "Main" and click OK.

Ungroup the records: If you grouped the records, ungroup them by returning to the view you were working in before.

Back to top

How can I duplicate an index entry, swap the main and subheadings, and then combine the subheading with the main heading separated by a space?

Select the entry by choosing Edit | Select Entry (Ctrl+Space)

Choose Edit | Duplicate, Swap & Combine (Ctrl+F9)

Back to top