ProductsStoreSupportDownloadsNews

SKY Index Professional Tips

NOTE: These tips were written for SKY Index Professional v6.0, but some are applicable to version 7.0 as well.

The tips below have been extracted from the SKYIndexUsers Archive of Yahoo’s eGroups forum. They were kindly posted by Michael Wyatt and have been modified by formatting them for the web and by performing some minor editing.

Although we have no reason to doubt the accuracy of these tips, they have not been tested by SKY Software and it is recommended that you try these tips on a test index prior to use as part of your daily indexing. ALWAYS MAKE A BACKUP OF IMPORTANT INDEX DATA BEFORE PERFORMING A SIGNIFICANT EDITING TASK!!!

Available Tips:

Entering International Characters
Demoting multiple records
Working with formatted text
Managing page references
Alternative fonts
Introductory notes
RTF style tags
Browsing
Locators containing a leading zero
Text Editor box
Printing drafts
Undoing formatting
Default index
Embedding index entries in Word files
Character map
Acronyms
Working in teams
Non-standard page runs
Creating a spell check dictionary file from an index
Deleted and marked records
Page numbers beginning with zero
Right-clicking for the context menu
Start menu
Duplicating a heading as a subheading, or a subheading as a heading
Capitalizing initials
Orphan cross-references
New Edit menu items
British spelling dictionary
Using an ellipse to begin a list of locators

Demoting multiple records

Sometimes you will have established a compound heading in the form of a phrase, and then you find you need to split it into a heading plus subheading. How do you do this easily if you have already attached a number of locators to the heading?

Let's say you have established the heading "goals at work" and attached half a dozen page references. Now you find that "goals" have cropped up in a different context, so you want to change your earlier entries to the heading "goals" with the subheading "at work".

  1. Create a group: Highlight one instance of the heading and create a group by clicking the "Grouped" speedbar button, pressing Shift+F6, or choosing" View > Grouped". (Actually, you can omit this step, but I like to include it so that I can check that what I expect to happen is what actually happens.)
  2. In one of the records insert a comma after "goals".
  3. Propagate the change: Press Ctrl+Alt+Enter, so that all the records read "goals, at work"
  4. Select all the records: If you have grouped them, press Ctrl+Insert or choose Edit > Select All; if you have not grouped them, press Ctrl+Space or choose Edit > Select Record.
  5. Demote: Click the "Demote" speedbar button, press Ctrl+F6, or choose Edit > Demote.
  6. When the "Select field" box pops up, choose "Main" and click OK.
  7. Ungroup the records: If you grouped the records, ungroup them by returning to the view you were working in before.

Working with formatted text

In version 6, you apply formatting to individual strings of characters text in the same way as in version 5.1

However, there are a couple of changes in version 6:

By default, text in the data entry grid is displayed as formatted, not surrounded by formatting codes as in version 5.1.

If the formatting runs to the end of the cell, you don't have to switch off the formatting; SKY Index will do that for you automatically when you move to another cell.

This is a great improvement over the codes that used to clutter up the data entry grid in version 5.1. Now, what you see is what you get.

However, although you can't see the formatting codes, they are still there. You can verify this by typing in some text together with the actual codes -- try typing "/i1This text is in italics/i0" and then press the return key. This creates a challenge when you are using AutoComplete (this used to be called AutoEntry in version 5.1); and also when you are using the Find/Replace dialogue. In both of these cases you must type the formatting codes at the beginning of the text.

AutoComplete

For example, let's say you are indexing a book on the history of cinema, where there are going to be a lot of names of films in italics. You know you have already typed in "Battleship Potemkin" in italics, and you can't face typing it again, so you want AutoComplete to do it for you. For AutoComplete to complete your typing you must begin by typing "/i1Battleship ...". (You can set up a macro to insert "/i1"). To check this out, type a couple of headings in italics or bold and then look for them in the AutoComplete Manager.

Find/Replace

Similarly, let's say you want to find all records that contain a cell at any level that begins with the word "Battleship" in italics. In the Find/Replace dialogue box's Find What textbox you would type: </i1Battleship. Check it out by typing some text in bold, italics, or underlined, highlight it and press Ctrl+F -- the highlighted text appears in the Find What textbox together with its codes. Neither the Find What textbox nor the Replace With textbox allows you to insert formatted text in the same way as the data entry grid. Instead, you can insert formatted text by typing the formatting codes either side of it. Maybe this sounds like a bit of a hassle, but it actually has an enormous benefit: It means that you can find and/or replace the formatting itself without having to specify text. Let's say you need to change all italic page references to bold -- in the Find What textbox you would type /i, and in the Replace With textbox you would type /b, and choose the Page field.

Hide and Ignore text

Although the methods for invoking Hide and Ignore text remain the same as in version 5.1, the codes that version 6 inserts are different. You will notice that under default conditions, Hidden text is displayed in the data entry grid as blue, and Ignored text is displayed in green. However, the codes that SKY Index inserts in the background are /z1 and /z0 either side of Hidden text, and /y1 and /y0 either side of Ignored text. Check it out: code some text as Hidden or Ignored, highlight it and press Ctrl+F. Thus, if you are using AutoComplete for the name McDonald, for example, and you know that you have "hidden" an "a" between the M and the c, you would need to begin typing: M/z1a/z0cDonald.

Reveal codes

You can switch on the display of formatting codes: Choose Options > Program Options, click the Data Entry tab, and place a checkmark next to Reveal Codes. For most of the time it is a great advantage to have the codes suppressed. But I have occasionally found it useful to "reveal" them when I have totally stuffed up a "Hide/Ignored" combination and need to sort it out; or imported an index from someone else's TXT file and need to fix up a formatting mess they created; or I am using a monochrome monitor and have to be able to distinguish Hidden and Ignored text.

Managing page references

Version 6 has some new commands for incrementing and decrementing page references. You must be in View mode, but the marquee can be over any cell, not just the page cell.

A short while ago I described some macros for managing page references. Here they are again, updated for version 6. There are two things to note:

  1. All macro commands must be typed in lower case. Yes, I know that the examples in the online Help are in capitals, but you must enter them in lower case or they won't work

  2. Before invoking these macros, you must be in View mode and the marquee must be over the page cell. (The very useful Alt+F2 has not been retained in Version 6)

To remove the second number and dash from a page range and move to the next record (e.g. to change 37-42 to 37): {f2}^{bs 2}\

Alternative fonts

You can now insert characters from up to two other fonts into your indexes. This is very useful when you have to insert special symbols, such as an alpha or beta into names of chemical compounds or of stars.

Setting the alternative fonts: In the Index Options dialogue box, click the Fonts tab and then click the "Alternative fonts" button. You will see that there are already two fonts set up by default (if they are installed on your computer): Alternative font 1 is Courier New, and Alternative font 2 is Symbol. The Font Preview box shows you what they look like -- if the preview box is blank just click the name of the font and it will show up. You can choose any font that has been installed on your computer. The fonts you choose will have no effect on your index until you actually apply them.

Applying the fonts: To change the font of a string of text, highlight the text (or to change the contents of an entire cell, change to View mode) and either choose Format > Alternative font 1 (or Alternative font 2); or press Alt+F1 (or (Alt+F2).

It is important to remember that for the normal text of any index the font used to display the index in the SKY Index screen (set up in Program Options > Program Font) is generally different from the font used to output the index (set up in Index Options > Fonts). Only the Alternative fonts display and print using the same fonts.

Introductory notes

You can now insert introductory notes at the front of your indexes. In the output RTF file they will be coded as IndexNote.

To insert an introductory note, in the Index Options dialogue box click the Header/Footer tab. Type your introductory note in the "Introductory Note" textbox. You can format text by highlighting the text to be formatted and pressing the usual Ctrl+I for italics, Ctrl+B for bold etc.

Although the introductory note appears in the Header/Footer tab, it is inserted at the head of your index even if you choose "RTF (no headers)" in the Output tab

RTF style tags

In version 5.1, when you chose RTF output the style tags were preset and could not be altered: The main heading was called Main, the first subheading level Sub1, the second subheading level Sub2, and so on. This occasionally caused problems for the typesetter, especially if they had already set up the styles for the index in their typesetting or word-processing program. Although it is possible in Word to change the names of style tags, if you don't know how to do it, it is quite difficult and unintuitive. Moreover, many editors and typesetters are unaware that it can be done at all, and will go through your index manually inserting tabs for each subheading. We've all seen indexes that's happened to -- yecch!

Now you can get SKY Index to output an RTF file using any style tag your client specifies. In the Index Options dialogue box click the Fonts tab. Along the top is a series of "radio buttons" marked Sep, Main, Sub1, etc. Click the appropriate radio button for the level you want to rename. In the "Style Name" textbox is the default style tag that SKY Index will insert. You can overtype this name with whatever the client has specified.

Try it. Open an index (I always use an index that I call "deleteme" specifically for this kind of test). Print it to your word-processor. In the word-processor click on a main heading. In the list of style tags (in Word this list is usually the first box in the toolbar below the speedbutton icons) notice that the term "Main" appears. As you click on a subheading it changes to "Sub1", and on a separator it changes to "Separator". Close the word-processor.

Back in SKY Index, open the Fonts tab, click the Main button, and in the Style Name box type "Top level". Click the Sub1 button and in the Style Name box type "Second level". Click OK. Print it to your word-processor again. Click on a heading and a subheading, and watch the style tag list box.

Browsing

Have you discovered the Browse function yet? Zowie!

Either choose Search > Browse, or press Ctrl+Alt+B. The Browse Mode box pops up. Just start typing, and both the preview pane and the data entry grid snap to the closest entry they can locate. As soon as the entry you are looking for appears, you can stop typing and press Esc.

If you have a lot of subheadings under a heading, as soon as the heading is highlighted on the screen, stop typing (you don't have to finish typing it) and press the semicolon key -- anything you type now will be searched as a subheading of the highlighted heading. You can use as many semicolons as you have subheading levels.

To start a new search, simply press the enter/return key to clear the Browse box, and start typing again.

I find the browse function particularly useful when I am proofing editing changes that I made to a draft index.

Locators containing a leading zero

I have been indexing a large procedure manual, where the section number is used as the locator. The section number consists of the chapter number followed by a section number, separated by a full stop (period). All section numbers under ten are preceded by a zero.

This doesn't seem to be a problem with single locators, such as 1.05. However, where there is a range, such as 1.05-1.25, SKY Index suppresses the initial zero and displays 1.5-1.25.

Evidently, this is because of the way SKY Index handles locators. The solution (provided by Kamm) is to enter a tilde instead of a leading zero, and use the translation feature in the Locators tab of the Index Options dialogue to convert the tilde to a zero.

Thus, I enter 1.~5-1.25, which displays in the Preview Pane as 1.05-1.25.

Text Editor box

If you have a heading or subheading that is too long to be completely visible in a data entry grid cell, you have several options: * You can adjust the width of the column by grabbing the column divider in the grid's header and moving it across. * You can adjust the depth of all rows by grabbing a row divider in the record button column and moving it down. * You can put up with seeing only a bit of the text at a time.

All of these have their familiar disadvantages.

But now in version 6 we have (ta da!) the Text Editor. With your cursor in the cell you are editing (either in Edit mode or View mode, it doesn't matter) press Shift+F2. The whole of the contents of the cell appears in the Text Editor box. You'll notice the text is highlighted: to get to the beginning press the Home or left arrow key; to get to the end press the End or right arrow key. You can type as much or as little in the Text Editor box as you please: you can even type a small novel if you want.

The Text Editor box works like other Windows boxes -- you can: * resize it: grab an edge or corner and pull it * move it around: hold down the mouse button over the colored bar along the top and move the mouse * maximize it: click the square in the top right corner.

In the Text Editor box you have the full range of editing and formatting options that are available during normal editing, using the Text Editor's own Edit and Format menus. You can even use the normal editing and formatting keyboard shortcuts. The only thing you can't use is the speedbutton icons. (A warning: If you format text as Small Caps it will display in the Text Editor as strikethrough text. It appears correctly as soon as you exit the text box and move to a new cell.)

In addition, the Text Editor has a great feature that is not available when you are editing within the grid: you can highlight text and then drag and drop it elsewhere in the Text Editor. If you hold down the Control key while you drag, the text will be copied rather than cut.

When you've finished entering or editing text, either click OK or press the enter key to place the text in the correct cell; or click cancel or press the Esc key to abandon the changes.

Printing drafts

To print a draft of your index, you no longer have to "print" to a word-processor, and then print from that. You can simply choose File > Print draft and SKY Index will use WordPad to print the index directly.

Note: There will be no headers, footers, or columns. You will need to "print" to your word-processor to see those.

Undoing formatting

If you have formatted text as italics, bold, etc., you can easily undo it: Highlight the text (or choose View mode) and either choose Format > Plain or press Alt+F10.

Default index

In version 5.1 you were able to set up default options for all new indexes by saving an empty index as default.skx.

In version 6 this is done through a template called default.tpl.

To convert your default.skx index for use in version 6, open it (you may have to do a bit of clicking and searching to find it) and save the properties as a template: choose Options > Export Index Options. A "Save File As" box will appear, with the Templates folder already selected. In the File Name textbox type "default" and click Save.

From now on each time you create a new index the default template will be applied. SKY will ask you a short series of crazy questions, but put up with it -- it's worth it! You can update it at any time simply by exporting any index's properties as default.tpl.

Embedding index entries in Word files

You can drag index entries from SKY Index directly into a Word file, and the resulting embedded index entries will be formatted correctly for index generation. The Word file with its embedded index entries can be imported into any other program that fully supports RTF index codes. I have not tested many desktop publishing programs; I do know that Ventura Publisher imports the index codes correctly, but that Quark Xpress (the default industry standard in Australia) does not. Perhaps some of you could experiment with PageMaker, FrameMaker, InDesign, MS Publisher etc and let us know how well these import embedded index terms.

Of course, you still have to create the index manually before you embed the terms in the Word document, but you do save yourself the time of manually retyping them yourself into the Word document+.

  1. Open your completed index in SKY Index. Display it in Page Ordered or As Entered order, or whatever order reflects the order in which you will carry out the embedding.
  2. Open the document that is to receive the embedded index entries in Word -- use a copy, not the original! Make sure you have the Show/Hide speedbutton (the one with what looks like a stylized back-to front P) depressed -- each word is separated by a dot, and each paragraph ends with the back-to-front P (called a Pilcrow sign -- I learnt something new today) -- otherwise you won't be able to see your index entries.
  3. Tile SKY Index and Word side by side on your monitor's desktop. You only have to have the Main column visible in SKY Index.
  4. Embed index entries one by one:

a.       Highlight a record by clicking on its record button.

b.       Grab any cell (I use the Main cell) and drag it across to the Word document.

c.       Drop the entry in the appropriate place in the Word document. If you have never embedded index entries before, you'll notice that each entry is enclosed in curly braces; it begins with "xe " (telling Word it's an index entry); the index data is enclosed in second marks (like ditto marks); and levels of subheading are separated by a colon. All elements except the braces can be edited.

d.       Exclaim in amazement and delight.

  1. To generate your index when you have finished, or if you want to check progress part way through, click the Show/Hide speedbutton again to hide the word-space and paragraph-end symbols, otherwise the page numbers will come out all wrong.
  2. Place your cursor at the end of the document, in a new paragraph. Choose Insert > Index and Tables, and choose your options in the Index tab.
  3. Click OK.

Notes:

·         Sorting instructions: If you have used sorting overrides ("Hide Text" and/or "Ignore Text"), or if your the index is to be sorted letter-by-letter instead of word-by-word, you can ask SKY Index to include sorting instructions in each index entry that you drag into the Word document. In SKY Index choose Options > Program Options and in the Preferences tab place a checkmark beside "Include sort information when embedding". Sort information will be included in ALL entries that you drag across. You'll notice in the Word document that the sort information appears for each level of heading and subheading, from which it is separated by a semicolon.

·         Cross-references: When you drag cross-references across to Word, SKY Index automatically formats them correctly by inserting the symbol "\t". Word has no way of verifying the validity of cross-references.

·         Page spans: Word manages page spans by using what it calls "bookmarks". You can insert named markers anywhere in the text to create these bookmarks; creating page spans is only one of the number of uses that Word puts bookmarks to. When you create an index entry for a span in Word, you (1) insert a bookmark at the end of the span, (2) insert the index entry at the beginning of the span, and (3) in the index entry insert the name of the bookmark, which Word precedes by the symbol "\r". Clearly, SKY Index has no idea where the span ends, so whenever you have used a page span in an index entry, SKY inserts after the "\r" symbol the text "SKY0001". You must create a bookmark and overwrite "SKY0001" with the name of the bookmark in every case, otherwise you will get error messages when you generate the index in Word. As far as I know, there is no way to set formatting preferences for page spans (simple, aggressive or Chicago) in Word.

Character map

Version 6 has its own character map; it no longer relies on the Windows character map. This has advantages and disadvantages. The advantages are: you don't have to install the Windows character map on your computer; and it's easy to find the fonts you need.

To invoke the character map, choose Tools > Character Map. From the dropdown list you can choose between the two Alternative fonts that you have set up (Options > Index Options > Fonts > Alternative Fonts), and the font you have chosen as your screen font (Options > Program Options > Program Font). If you choose the screen font, any character you choose will be output in the font you chose for output (Options > Index Options > Fonts).

The buttons down the right of the dialogue box are a little confusing. I'll explain them as I go along.

  1. Place your cursor where you want the special character to appear.

  2. Choose Tools > Character map.

  3. Choose the font.

  4. Either click the character you want and then click Copy; or double-click the character you want. Either way, the character will appear in the little box at the top marked "Characters to copy". Keep on choosing characters till you have all you want.

  5. To insert the characters in the index, click Insert.

The disadvantage is that you no longer have the keystroke tips available, so you can't make a note of the ones you use most commonly. For this reason, I have listed the keystrokes below for some of the commonly used special characters (out of a total of 128) that appear in your screen font, so that you can bypass the Character Map. In each case, hold down the Alt key, press the numbers on the numeric keypad on the right of your keyboard (not the ones along the top of the keyboard), and then release the Alt key. Since the characters below may not display correctly on your email screen, I have added the explanations that appear in the Windows character map just in case.

Many books on Windows contain a chart showing the complete symbol set of all 128 characters. I have created such a chart for standard fonts such as Times New Roman and Courier New. If you would like a copy, email me offlist.

You can incorporate special characters into acronyms and macros. For example, to set up a macro to type the letter e acute (é):

  1. Click the <New Macro> button to invoke the macro editor

  2. Put the cursor in the Macro textbox

  3. Hold down the Alt key and press 0233. You can do the same in the Acronym Editor for words containing special characters.

If you don't know the code for a special character:

  1. Open the Character Map

  2. Double-click the character

  3. Click Select

  4. Press Ctrl+C

  5. Click Close

  6. Open the Macro Editor

  7. With your cursor in the Macro textbox, press Ctrl+V

  8. Click OK

If you want to use a symbol from the Symbol font, then (assuming that the Symbol font is set up as Alternative font 2) at step 7: a) type %{f2} b) press Ctrl+V c) type %{f2}

Acronyms

As well as when you type a space, did you know that Acronyms now expand when you press any key that takes you to another cell -- enter, tab, backslash, or any of the cursor keys?

Acronyms have been greatly improved in Version 6. They have their own dockable toolbar along the top of the screen. To set up a single acronym, simply click the <New Acronym> button in the toolbar, and type the acronym and its expansion in the Acronym Editor. There is no limit to the length of the expansion.

To enter several acronyms at once, or to manage your acronyms, call up the Data Entry Options dialogue box; the Acronyms tab is on top. The acronyms and their expansions are displayed in a grid just like the data entry grid -- you can use exactly the same editing and formatting keystrokes as when you are doing data entry in the index, including Ctrl+A to append a new acronym and Ctrl+I/Ctrl+B for italics and bold. Pressing Shift+F2 with your cursor in a cell takes you to the Text Editor, where you have the full range of options that is available when you use the Text Editor editing index records. There is no limit to the number of acronyms you can have, although only the first 40 will be displayed in the Acronym toolbar. To sort the acronyms into alphabetical order, click the Refresh button.

Are there words that you consistently mistype? If so, you can use Acronyms as an auto-correct feature. Type the misspelt versions into the Acronym textbox and the correct spelling into the Expansion textbox in the Acronyms tab of your default template. Then whenever you type a word incorrectly, SKY Index will automatically correct it for you. For example, in indexing recipe books I invariably type "prok" instead of "pork". I have set up the acronym "prok" and its expansion as "pork", so that whenever I type "prok" SKY Index automatically corrects my spelling to "pork".

Working in teams

When you are working in team, you can keep track of who created records and when they created them. The team leader can also edit records and record the date edited.

When you create a record, SKY Index attaches to it the initials that you typed in Program Options when you installed version 6, as well as the date you created the record. When that record is modified, SKY Index also attaches the initials of the person who modified it and the date it was modified. You can view all this information by going to the View menu and choosing Creator, Edited, Date Created and Date Edited.

To retain this information when merging indexes, you must use Merge. You can't use Export and Import, because when you Export an index you lose the information about creation and editing information.

If you're having problems swapping large files, take a Snapshot of the file and send that instead (the filename ends with .SNP). The receiver can create a new index with the same name then choose Revert.

Non-standard page runs

On a couple of occasions I have had a client specify that page runs be treated in a non-standard way. On one occasion, a client didn't like the fact that "Aggressive" setting reduced 1095-1103 to 1095-103, which I had to agree looked pretty strange. Another client specified that page numbers were to be "aggressive" when only the last digit changed, but "simple" when the last two digits changed. Yikes!

How do you override the SKY Index page run settings for individual locators? Short of examining every locator in the output RTF file and changing it manually, that is.

The answer turns out to be very simple -- thanks to Kamm for providing this one. In the Locators tab, click the "Translation table" button. In the Translate column type "@" and in the the To column type a hyphen, en-dash or whatever you have set the page run separator to (to enter an en-dash hold down the Alt key and type 0150 on the numeric keypad). Then when you are typing a page range that you don't want SKY to modify, type @ instead of a hyphen. For example, for the client who didn't want 1095-1103 to be reduced to 1095-103 when using the "aggressive" setting, I typed "1095@1..." and SKY interpreted it as "1085-1103".

Creating a spell check dictionary file from an index

 You've just completed a huge index with heaps of specialist terms, proofread it meticulously, and delivered it. The client was so impressed they want you to do another one on the same subject. Can you face all that proofreading again?

Thankfully, you can use your earlier index to create your own dictionary of specialist terms.

The instructions below look complex, but once you've done it you'll see how easy it is.

1.       CREATE A DICTIONARY FILE:

a.       Open the index and "Save As" with a new name.
b.
       Open the Find/Replace dialogue box.
c.
       In the Find What textbox type an asterisk. Leave Replace With blank. Place a checkmark next to Use Pattern Matching. From Field choose Page.
d.
       Click Find, then Replace All.
e.
       In the Index Options dialogue box select the Output Format tab.
f.
         Select the "Text (ASCII)" preset.
g.
       Delete everything in the boxes, including the spaces next to Sub1, Sub2, Sub3.
h.
       Select the Style tab and uncheck Alphabet separators and Space before.
i.
         Click OK.
j.
         Print the index to Word.

2.       EDIT THE DICTIONARY FILE:

a.       Open the output file in Word (it will have the extension .TXT).
b.
       Open Find and Replace dialogue box.
c.
       In the Find what textbox type a space.
d.
       In the Replace with textbox type ^p (circumflex followed by a lower-case letter p).
e.
       Click Replace All, then Cancel.

3.       SORT THE DICTIONARY FILE: EITHER (this method involves fewer operations, but if there are many duplicates you will end up with a larger and possibly slower file):

a.       Select all the text (Ctrl+A).
b.
       Choose Tables > Sort, and click OK.
c.
       Edit the file by removing numbers, punctuation, parentheses, quote marks etc. The Find and Replace box can help you do this quickly.
d.
       Save the file and close Word.

OR (this method involves more operations, but removes duplicate terms thus reducing the file size):

a.       Save the file and close Word.
b.
       Open SKY (or close any index that is open).
c.
       Choose File > Import.
d.
       Select the text file and click Open.
e.
       In the Input Field Mapping box uncheck Fields Are Enclosed In Quotes, and click OK.
f.
         Either type a new name for the index, or overwrite the earlier temporary index, and click OK.
g.
       Choose Tools > Remove Duplicate Records and click OK.
h.
       With the index still in sorted order, edit it by removing numbers, punctuation, parentheses, quote marks etc. Use Find/Replace to help you.
i.
         Set the output for Text output as above.
j.
         Generate the index.

4.       INSTALL THE DICTIONARY FILE:

a.       Open Windows Explorer.
b.
       Replace the new dictionary name's extension .TXT with .DIC.
c.
       Move the dictionary to the My Documents\SKY Index\Templates folder.
d.
       In Sky Index, choose Options > Program Options > File Locations.
e.
       Next to User Dictionary click the button with three dots.
f.
         Select the new dictionary and click Open, OK.

Deleted and marked records

Deleted records    In Version 6, when you delete a record, it's not actually removed from the index. You delete records in the same way as you did in version 5: select a record or records and press the Del key. But instead of disappearing, the records are marked to show that they are to be deleted, by being displayed in the data entry grid as red (you can change the color in Program Options). Deleted records are indicated on the Proofing Report by a letter x next to the record number. You can undelete records by selecting them and pressing Alt+Del. When you are sure that you want to remove deleted records permanently, choose Tools > Remove Deleted Records.

You can hide the deleted records from view by opening the filter (choose View > Filtered, press Shift + F9, or click the Filter speedbutton), and checking "Hide Deleted Records". When you delete a record while you have "Hide Deleted Records" switched on, it disappears from the preview pane, but doesn't disappear immediately from the data entry grid -- that would be too distracting -- until you refresh the grid by pressing F5. Hiding deleted records from view also hides them from other processes like printing, find/replace, spell checking, statistics, and exporting.

If you want to remove a record immediately and permanently, select it and press Ctrl+X.

Marked records:   The ability to mark or label records is new in version 6. It works just like deleting records, except that you can't remove them from the index as a bloc using Tools. Select a record or records and press Ctrl+M. The records are displayed in magenta (you can change the color in Program Options), and are indicated in the Proofing Report by an exclamation mark next to the record number. You can unmark records by highlighting them and pressing Ctrl+Alt+M.

You can display or hide marked records by using the Filter, in the same way as deleted records.

Some of the ways that I have used marked records: * To create two indexes for the same book simultaneously. * To keep track of records being charged at a different rate. * To annotate records to be queried with the editor or author * To keep a record of cross-references made to a heading (what librarians call "tracings")

I'm sure you'll think of many other uses.

Page numbers beginning with zero

A regular client has sent me a book on the information communications industry. As part of the fancy up-to-the-minute design, the pages numbers all have three digits, so the pages run 001 to 009, then 010 to 099, and then 100 on. Cute huh?

Well SKY Index doesn't think it's so damn cute. Like me it wants strip those redundant leading zeroes and trash them. How do I get SKY to chill out?

1. Open the Locators tab of the Index Options dialogue box 2. Click the Translation table button. 3. In the Translation column type @ (or any other symbol), and in the To column type 0 (zero). 4. Click OK, OK.

To enter the page number 030, type @30, and the number displays in the Preview pane as 030.

The page numbers sort correctly: @@1 to @@9, then @10 to @99, and then 100 on. They increment and decrement correctly when you press the plus and minus keys. For page runs containing @ you have to type the complete run manually, but they do format correctly. I even tried combining them with volume and chapters, and they still format correctly.

This solution probably works with Version 5 too. I haven't tested it. Why should I? I'm making so much money by using version 6 that I've junked version 5 completely.

Right-clicking for the context menu

Some of SKY Index's most commonly used functions can be accessed using by clicking the mouse's right button. This saves you having to remember the keyboard shortcuts, or spending time searching menus for these commands.

Hover your mouse over one of the cells in the data entry grid and press the right mouse button. (Note that you need to be in view mode.) A special menu pops up, divided into three sections: the top one deals with cutting and pasting; the middle with duplicating; and the bottom one with moving the contents of cells. Have a look at the context menu today -- it could save you a lot of time in the future.

You can also right-click over records in the preview pane. When you do this a menu pops up with the same options, minus the cutting and pasting ones. I find this of limited value, since if there is more than one record for an entry some of the actions affect only the record with the lowest page number.

Like to keep your hands on the keyboard? If you have a Windows keyboard, you can press the Context Menu key instead -- that's the one just to the left of the right-hand Control key. The context menu that appears acts on whichever cell is highlighted in the data entry grid. To select a command, either press the up or down arrows on your keyboard, or press the key for the underlined letter.

Start menu

You will already have discovered that version 6 installs a SKY Index shortcut on the Start menu. To start SKY Index all you have to do is click the Windows Start button (or press the Windows key) and then select "SKY Index Professional".

But did you realize that SKY Index puts a shortcut for recently edited indexes in the Windows Documents menu? Click Start, point to Documents, and then click on the name of the index you want to open. SKY Index starts and opens the index, ready for you to add or edit records

Duplicating a heading as a subheading, or a subheading as a heading

To duplicate a subheading as a main heading:

If you type a heading followed by a subheading, you can turn that subheading into a new heading in its own right: Place the marquee over any cell and press Control + Alt + P (note that there is no Edit menu item for this command).

 To duplicate a main heading as a subheading:

If you type a main heading, you can turn that main heading into a subheading of a new main heading: Press Control + P (or choose Edit > Duplicate & Swap). The marquee will be over the new blank main heading ready for you to start typing.

Capitalizing initials

In version 5 if you needed to have the initial letter of all main headings capitalized you used the AutoCapitalize feature, which capitalized initials as you typed.

In version 6, in addition to AutoCapitalize you now have the option of setting SKY Index to capitalize initials at the formatting stage instead of at the data entry stage. I much prefer this way, because it gives me the option of changing my mind (or more likely the editor changing his/her mind) part-way through, without having to worry about the capitalization of proper names.

  1. In the Index Options dialogue, click the Fonts tab.
  2. In the top row (marked "Applies to") make sure the radio button next to "Main" has a dot in it.
  3. In the bottom left of the box is an area headed "Attributes". Click "Init. Caps" to place a tick in the checkbox.
  4. Click OK. You'll notice that whereas the main headings in the Entry grid display exactly as you typed them, the initial letters are capitalized in the Preview pane.

But what happens when you enter cross-references? If you type a capital initial after "see" or "see also", the AutoComplete feature won't kick in, right? Wrong.

  1. In the Data Entry Options dialogue, click the AutoComplete tab.
  2. Click "Ignore Case" to place a tick in the checkbox.
  3. Click OK. Now when you type a capital initial after "see" or "see also", SKY Index will complete the term for you with a capital initial, whether or not you typed the original term with a capital initial.

Orphan cross-references

Many clients specify that they want "see also" cross-references to appear as subheadings, as either the first or the last. You set this option in the Cross-references tab of Index Options. In the Placement row of the See also column choose "Top" or "Bottom", and click the "Preview" button to see how it will look.

The example in the Preview box is: grapes, 4-10 see also fruit green, 5 red, 7 or grapes, 4-10 green, 5 red, 7 see also fruit (Let's ignore for the moment the wisdom of making references from the specific to the general.)

But occasionally you will want to make a "see also" cross-reference from a heading that has no subheadings. Normally it would look like this: fruit, 20-25 see also grapes

Some clients specify that if there are no subheadings attached to a heading, then the cross-reference must appear on the same line as the heading, either before the locators or after them. This may also be your preference even if a client does not specify it. For example: fruit, 20-25. See also grapes or fruit (see also grapes), 20-25

How do you do this?

At the bottom of the Cross-references tab is a section called "Merge orphans to". By default it is set at "Don't". To get the cross-references to appear before the locators in such cases, choose "First"; or to appear after the locators, choose "Last". Enter any punctuation and/or parentheses in the "Prefix" and "Suffix" boxes below. There is no example of an orphan cross-reference in the Preview, so you'll have to check such entries in the index itself.

Using this strategy you can easily attain a format like: fruit (see also grapes), 20-25 grapes, 4-10 see also fruit green, 5 red, 7

New Edit menu items

The Edit menu in Version 6 contains many new functions. Listed below are the functions new since the version 5.1.

You can find explanations of by pointing to the menu item and pressing the F1 key.

Note that some of these functions don't work if you have set the sorting option to "Sort this heading by page". Instead, you get an explanatory message.

COLLECT PAGES (Ctrl+Alt+C) and PASTE PAGES (Ctrl+Alt+V)   These functions allow you to copy all the page reference from one index entry to another.

For example, you may want to double-post an entry that already has a number of page references. Let's say you already have dog breeding 13, 17, 21-29, 40-43 and you want to double-post it at breeding dogs 13, 17, 21-29, 40-43 In version 5.1 it was a messy business: either you had to retype the page references; or you could duplicate the records, group them, and overtype the heading. Now all you need to do is this:

  1. Click anywhere on any of the records for "dog breeding"

  2. Choose Edit > Collect Pages (or press Ctrl+Alt+C)

  3. Append a new record and type "breeding dogs"

  4. Choose Edit > Paste Pages (or press Ctrl+Alt+P)

UNDELETE, MARK, and UNMARK I have already explained these in earlier postings.

SELECT HEADING (Ctrl+H)   Use this to select all the records for an entry at any heading level you choose. For example, to select all the records for a main heading, click the main heading for any of the records with that heading and choose Edit > Select Heading (or press Ctrl+H). Or to select all the records for a particular subheading of a main heading, click the Sub1 for any of the records and press Ctrl+H.

The online help has this to say:

Assume you have the following set of entries (ignoring locators):

      bicycles
                buying
                maintenance
                repairs

and you want to create the following entries:

      cars
                buying
                maintenance
                repairs

Simply put the grid marquee over the main heading of any record that has the main heading 'bicycles' and press <Ctrl><H>. Then duplicate entries by choosing Edit|Duplicate, and group the entries by choosing View|Grouped. Finally, change any one of the 'bicycles' main headings to 'cars' and press <Ctrl><Alt><Enter> to propagate the edit through the entire group.

DUPLICATE ENTRY (Ctrl+Q)   This function selects all the records for an entry and then duplicates them. In effect, it's really a "shortcut shortcut" -- instead of choosing Edit > Select then Edit > Duplicate (or pressing Ctrl+Space then Ctrl+D), you now just select Edit > Duplicate Entry (or press Ctrl+Q).

DUPLICATE HEADING (Ctrl+F8)   This is another "shortcut shortcut". It's the equivalent of choosing Edit > Select Heading followed by Edit > Duplicate followed by View > Grouped (or pressing Ctrl+H then Ctrl+D then Shift+F6).

Have another look at the example above for duplicating the set of entries for "bicycles" under "cars". Instead of pressing Ctrl+H, then duplicating the entries and finally grouping them as described above, just press Ctrl+F8.

COMBINE (Ctrl+F7)   This is exactly the same as "Promote", except that instead of inserting a comma (or whatever Promote separator you have specified) SKY Index simply inserts a space. Use it in the same way as Promote: place the cursor in or the marquee over the right-hand cell of the two cells you want to join, and choose Edit > Combine or press Ctrl+F7. Like Promote, you can also use Combine with several records at once: select the records and choose Edit > Combine or press Ctrl+F7: a box pops up asking you which heading level you want to combine.

Why do we need this in addition to Promote? In many cases a subheading can be better combined with its heading as natural language rather than by retaining the hierarchical look. For example, we may have assigned "safety : training". If we Promote the subheading, we create a new heading "safety, training". In version 5.1, if we wanted the new heading to read "safety training" instead, we had to press F2 and edit the comma out. But by using Combine we immediately create a new heading "safety training".

SHIFT RIGHT (Ctrl+Alt+F6)   This is just like the familiar Shift Left command, except that everything is shifted right instead. Place your cursor in or marquee over *any* cell in the record you want to shift right and choose Edit > Shift Right, press Ctrl+Alt+F6, or click the "Shift Cells Right" speedbutton icon (third from the right-hand end of the speedbutton toolbar); a dialogue box asks you to select the level of heading you want to shift. The left-most cell is left blank, with the marquee positioned over it ready for you to begin typing.

You can use Shift Right with a single record or several records at once.

Note that Shift Left, which in Version 5.1 was invoked by pressing Shift+F1, is now Ctrl+Alt+F5. If you press Shift+F1 in version 6, nothing happens.

SHIFT LEFT TO MAIN (Ctrl+Alt+5)   This works like Shift Left, except that it shifts the contents of a cell at any subheading level to the Main cell, deleting any higher levels.

Beware! You must select the entire record for this function to work. If you select only one cell, the contents of all cells are obliterated!

I hope that these explanations will tempt you exploit Version 6's power to the full. Or if you haven't upgraded yet, I hope they will help persuade you to do so.

British spelling dictionary

When you install version 6, the American spelling dictionary is installed by default. If you live in a country that does not use US spelling, you can install the UK dictionary instead.

  1. Choose Options > Program Options

  2. Click the File Locations tab

  3. Click the arrow in the dropdown box at the bottom of the dialogue labeled Main Dictionary

  4. Choose vssp_be.dct

  5. Click OK.

As well as accepting British spellings, this dictionary still accepts American spellings, so don't rely on it for an index you are converting for an overseas edition. Note also that it rejects words ending in -ise and -isation, preferred by some British publishing houses, and the norm in Australia. As it is not possible to edit the so-called "main" dictionaries, you will need to add such words to your user dictionary. (I'm not familiar with the spelling conventions in Canada and other English-speaking countries, so I can't say how well they are served.)

Using an ellipse to begin a list of locators

Those of you who are members of Index-L will have read the thread on alternatives to the comma or the space between an index heading and its locators. One of the suggested alternatives was the ellipsis. An example from a published legal index was provided:

    REMEDIES

    Failure to bargain
        Back pay...15.07[2]; 16.02[3]
        Status quo ante...15.07[3]; 16.02[3]
    Strikes, illegal
        Damages...6.03[1] et seq.
        Generally...5.07
    SENIORITY
        Absenteeism caused by...1.09[3]

How do you get the ellipsis character? You don't insert three dots, that's for sure -- otherwise a line break could occur between the dots, which would be most confusing.

Open the Index Options dialogue box and click the Locators tab. In the Locators--Leader textbox delete whatever is there. Holding down the Alt key, type 0133 on the numeric keypad, and release the Alt key. A vertical black block will appear in the textbox. Click OK and check the Preview pane.