SKY Index Professional 8.0 Tips and Techniques

NOTE: The tips are based on below apply to SKY Index Professional 8.0 (SI8) and are based on the SKY Index Professional 6.0 tips that were extracted from the SKYIndexUsers Archive of Yahoo’s eGroups forum and posted by Michael Wyatt. They have been modified where applicable to work properly with SI8, to provide more clarity and to better describe the problem being solved.

Although we have no reason to doubt the accuracy of these tips, they have not been tested by SKY Software and it is recommended that you try these tips on a test index prior to use as part of your daily indexing. ALWAYS MAKE A BACKUP OF IMPORTANT INDEX DATA BEFORE PERFORMING A SIGNIFICANT EDITING TASK!!!

Tips:

Entering International Characters

Automatic Initial Caps: How to set and override them

Splitting a main heading into main plus subheading (Demoting)

Working with formatted text

Managing page references (incrementing/decrementing)

Applying a font the way you would a character style (Alternative fonts)

Introductory notes

RTF style names/tags

Browsing/Searching

Locators containing a leading zero

Dealing with lengthy heading text

Printing a draft of your index

Removing formatting from text

Setting a default index style

Embedding index entries in Word files

Character map

Acronyms

Working in teams

Non-standard page runs

Creating a spell check dictionary file from an index

Right-clicking for the context menu

Duplicating a heading as a subheading, or a subheading as a heading

Capitalizing initials

Orphan cross-references

British spelling dictionary

Using an ellipse to begin a list of locators

Quickly go to the target of a cross-reference

How to duplicate an entry and swap the main and subheadings

How to create main headings from the subheadings of an existing set of entries

How to post all subheadings of an existing heading under a synonymous heading

How to keep track of both subjects and authors in a combined subject/author index

Demoting part of a heading for multiple records

How to duplicate an index entry, swap the main and subheadings, and then combine the subheading with the main heading separated by a space

How to rename a main or subheading that has many subheadings

Splitting a main heading into main plus subheading (Demoting)

Sometimes you will have established a compound heading in the form of a phrase, and then you find you need to split it into a heading plus subheading. How do you do this easily if you have already attached a number of locators to the heading?

Note: SKY Index includes a Demote command that will search for a comma within a heading and use that as a dividing point. If no comma exists, you can place the text cursor where you want the division to occur. The text before the comma will remain at the current heading level and the text after the comma will be moved down one level. If there is already text in the subheading level, the demoted text will be prepended to the existing text followed by a comma.

Let's say you have established the heading "goals at work" and attached half a dozen page references. Now you find that "goals" have cropped up in a different context, so you want to change your earlier entries to the heading "goals" with the subheading "at work". If there is more than one record in the grid with the same main heading, the technique below will allow you to demote every record simultaneously.

In the Index Pane

  • Highlight the main heading "goals at work"
  • Press F2 to enter Edit Mode
  • Place the text cursor between 'goals' and 'at work' either before or after the space.
  • Press (F6) or choose Edit>Demote

In the Grid

  • Place the blue marquee over the desired main heading in any grid record.
  • Duplicate and group the main heading by pressing (Ctrl+Shift+F6.)
  • In one of the records insert a comma after "goals".
  • Propagate the change: Press Ctrl+Alt+Enter, so that all the records read "goals, at work"
  • Select all the records by pressing Ctrl+A or choosing Edit > Select All.
  • Demote the text after the comma by pressing (F6) or choosing Edit>Demote.
  • When the "Select field" box pops up, choose "Main" and click OK.
  • Ungroup the records by pressing Ctrl+Shift+U or choosing Group>Ungroup.

Automatic Initial Caps: How to set and override them

To enable automatic capitalization of the first letter of every main heading, do the following:

  • Choose Options>Index.
  • Click the Heading Style tab.
  • Under Capitalization, check the Initial Cap option.
  • Click Save. (All main headings will now have the first letter capitalized automatically regardless of how you type the entry.)

Tip: For those entries that you need to override this setting, type a semicolon as the first character. The semicolon will be ignored (will not appear in the generated index) and the first letter of the heading will not be capitalized.


Working with formatted text

General

In SI8, you apply formatting to individual strings of characters text in the same way as you would in your word processor.

If the formatting runs to the end of the cell, you don't have to switch off the formatting; SKY Index will do that for you automatically when you move to another cell.

Although you can't see the formatting codes, they are there. If you want to see the text including the formatting codes, you can do so by choosing View>Reveal Codes. (Ctrl+Alt+E).

AutoComplete and Formatted Text

For example, let's say you are indexing a book on the history of cinema, where there are going to be a lot of names of films in italics. You know you have already typed in "Battleship Potemkin" in italics, and you can't face typing it again, so you want AutoComplete to do it for you. For AutoComplete to complete your typing you must begin by typing "/i1Battleship ...". (You can set up a macro to insert "/i1"). To check this out, type a couple of headings in italics or bold and then look for them in the AutoComplete Manager.

Find/Replace and Formatted Text

Similarly, let's say you want to find all records that contain a cell at any level that begins with the word "Battleship" in italics. In the Find/Replace dialogue box's Find What textbox you would type: </i1Battleship. Check it out by typing some text in bold, italics, or underlined, highlight it and press Ctrl+F -- the highlighted text appears in the Find What textbox together with its codes. Neither the Find What textbox nor the Replace With textbox allows you to insert formatted text in the same way as the data entry grid. Instead, you can insert formatted text by typing the formatting codes either side of it. Maybe this sounds like a bit of a hassle, but it actually has an enormous benefit: It means that you can find and/or replace the formatting itself without having to specify text. Let's say you need to change all italic page references to bold -- in the Find What textbox you would type /i, and in the Replace With textbox you would type /b, and choose the Page field.

Hide and Ignore text

Although the methods for invoking Hide and Ignore text remain the same as in version 5.1, the codes that version 6 inserts are different. You will notice that under default conditions, Hidden text is displayed in the data entry grid as blue, and Ignored text is displayed in green. However, the codes that SKY Index inserts in the background are /z1 and /z0 either side of Hidden text, and /y1 and /y0 either side of Ignored text. Check it out: code some text as Hidden or Ignored, highlight it and press Ctrl+F. Thus, if you are using AutoComplete for the name McDonald, for example, and you know that you have "hidden" an "a" between the M and the c, you would need to begin typing: M/z1a/z0cDonald.

Reveal codes

You can switch on the display of formatting codes: Choose Options > Program Options, click the Data Entry tab, and place a checkmark next to Reveal Codes. For most of the time it is a great advantage to have the codes suppressed. But I have occasionally found it useful to "reveal" them when I have totally stuffed up a "Hide/Ignored" combination and need to sort it out; or imported an index from someone else's TXT file and need to fix up a formatting mess they created; or I am using a monochrome monitor and have to be able to distinguish Hidden and Ignored text.


Managing page references (incrementing/decrementing)

SI8 has some new commands for incrementing and decrementing page references. You must be in View mode, but the marquee can be over any cell, not just the page cell.

Note: Although the actual keyboard keys being referenced are period (.) and comma (,) we use the character above those characters '>' and '<' respectively since they give an idea of what will happen when the key is pressed (increase or decrease).

  • To increment a single page number or to increment the left hand page in a page range (e.g. to change 37 to 38 or to change 36-38 to 37-38): press (Ctrl+>)
  • To decrement a single page number or to decrement the left hand page in a page range (e.g. to change 37 to 36 or to change 37-38 to 36-38): press (Ctrl+<)
  • To create a page range for a single page (e.g. to change 37 to 37-38) or to increase the right hand page of a range (e.g. to change 37-38 to 37-39): press (Alt+> )
  • To collapse a page range to a single page (e.g. to change 37-38 to 37) or to decrease the right hand page of a range (e.g. to change 37-39 to 37-38): press (Alt+< ) 

Applying a font the way you would a character style (Alternative fonts)

SI8 now allows you to use unlimited fonts in your indexes. You can do so by selecting text and choosing the font from a list. However you can assign your three most used fonts to the function keys F1, F2, and F3 so that you can apply that font using Alt+F1, Alt+F2, or Alt+F3 in the same way you would apply a character style like bold or italic. To do that...

  • Choose Options>Preferences
  • Click the Fonts tab
  • Under 'Quick Fonts' click the Choose button next to the desired function key and select the font you want applied when you hold down Alt and press that function key.
  • Click Save

Applying the fonts: To change the font of a string of text, highlight the text (or to change the contents of an entire cell, change to View mode) and hold down the Alt key and press function key F1, F2, or F3.

Tip

  • Pressing Alt+F10 will remove all font attributes from selected text.
  • Pressing Alt+Ctrl+F10 will remove both font and character style attributes.

Note: It is important to remember that for the normal text of any index the font used to display the index in the SKY Index screen (set up in Program Options > Program Font) is generally different from the font used to output the index (set up in Index Options > Fonts). Only the Alternative fonts display and print using the same fonts.


Introductory notes

To insert an introductory note:

  • Choose Options>Index
  • Click the Index Style tab.
  • Click the Introductory Note button.
  • Type your introductory note. Tip: You can format text by highlighting the text to be formatted and pressing the usual Ctrl+I for italics, Ctrl+B for bold etc.
  • Click OK.
  • Click Save.

RTF style names/tags

SI8 uses Word Styles to apply formatting to the various levels of your index if you generate the index in RTF or RTF (no header/footer) styles. It uses the names: Main, Sub1, Sub2, etc. Your client may instruct you to use different names.

You can use any style tag name your client specifies by doing this:

  • Choose Options>Index.
  • Click the Heading Style tab.
  • Along the top is a series of tabs named Sep, Main, Sub1, etc. Click the appropriate tab for the level you want to rename.
  • In the "Style Name" textbox type whatever name the client has specified.
  • Repeat for all heading levels of the index.
  • Click Save.

Browsing / Searching

Starting with SI8 you can now search directly in the Index Pane. To search in the Index Pane:

  • Give focus to the Index Pane. (If the grid has focus, press Ctrl+Tab or click in the Index Pane with the mouse.)
  • Now just start typing and the Index Pane will find the closest entry matching what you've typed so far. As soon as the entry you are looking for appears, press Esc to stop searching (see the Tip below).
  • If you have a lot of subheadings under a heading, as soon as the main heading is highlighted in the Index Pane, type a comma and start typing the desired subheading text. You can use as many commas as you have subheading levels.

Tip

There are settings in Preferences>Key Bindings that affect how different keystokes are handled when searching in the Index Pane. Please examine those settings so that you can setup SI8 to best suite the way you do your indexing.


Locators containing a leading zero

Unlike previous versions of SKY Index, SI8 will allow you to enter a locator with leading zeros. Just type the leading zeros if you need them.


Dealing with lengthy heading text

If you have a heading or subheading that is too long to be completely visible in a data entry grid cell, you have several options:

  •  You can adjust the width of the column by grabbing the column divider in the grid's header and moving it across.
  • You can adjust the depth of all rows by grabbing a row divider in the record button column and moving it down.
  • You can put up with seeing only a bit of the text at a time.
  • You can use the Text Editor (details below)

With the marquee over the cell you are editing (either in Edit mode or View mode, it doesn't matter) press Shift+F2. The whole of the contents of the cell appears in a separate Text Editor window. You'll notice the text is highlighted: to get to the beginning press the Home or left arrow key; to get to the end press the End or right arrow key. You can type as much or as little in the Text Editor box as you please: you can even type a small novel if you want.

The Text Editor box works like other Windows boxes -- you can: * resize it: grab an edge or corner and pull it * move it around: hold down the mouse button over the colored bar along the top and move the mouse * maximize it: click the square in the top right corner.

In the Text Editor box you have the full range of editing and formatting options that are available during normal editing, using the Text Editor's own Edit and Format menus. You can even use the normal editing and formatting keyboard shortcuts. The only thing you can't use is the toolbar icons (A warning: If you format text as Small Caps it will display in the Text Editor as strikethrough text. It appears correctly as soon as you exit the text box and move to a new cell.)

In addition, the Text Editor has a great feature that is not available when you are editing within the grid: you can highlight text and then drag and drop it elsewhere in the Text Editor. If you hold down the Control key while you drag, the text will be copied rather than cut.

When you've finished entering or editing text, either click OK or press the enter key to place the text in the correct cell; or click cancel or press the Esc key to abandon the changes.


Printing a draft of your index

To print a draft of your index, you no longer have to generate the index and then use your word processors Print command. You can simply choose File>Print draft and SKY Index will use WordPad to print the index directly. The advantage is that that there are fewer actions needed to get the index printed on paper. The disadvantage is that WordPad does not support multiple columns so your index will always print with a single column - wasting a certain amount of paper. In addition, the draft will not have headers or footers.


Removing formatting from text

If you have formatted text as italics, bold, etc., you can easily remove it: Highlight the text (or choose View mode) and either choose Format>Plain or press Alt+Ctrl+F10. If you only want to remove assigned fonts, choose Format>Remove fonts or press Alt+F10.


Setting a default index style

SI8's default settings for an index may be what you'd like for a common starting point. If that's the case, you can create your own default settings.

When SI8 creates a new index, it looks for a file named default.tp8. If that file exists, it will use the settings in that file as the default settings for the new index.

Creating a default.tp8 file

There are two ways to create a default.tp8 file. They are:

  1. Modify the settings of an existing index to the settings you'd like to use for all new indexes. Then choose Options>Save as Template. When you're asked to give the template a name, type 'default'.
  2. Close any open index and then choose Options>Index. If there is no default template, one will automatically be created. Now adjust the settings as desired. Click Save when you're done. Note: You can edit this template any time by closing all open indexes and choosing Options>Index.

Once you've created the default index template, each time you create a new index, that default template will be applied to the new index.


Embedding index entries in Word files

You can drag index entries from SKY Index directly into a Word file, and the resulting embedded index entries will be formatted correctly for index generation. The Word file with its embedded index entries can be imported into any other program that fully supports RTF index codes. I have not tested many desktop publishing programs; I do know that Ventura Publisher imports the index codes correctly, but that Quark Xpress (the default industry standard in Australia) does not. Perhaps some of you could experiment with PageMaker, FrameMaker, InDesign, MS Publisher etc and let us know how well these import embedded index terms.

Of course, you still have to create the index manually before you embed the terms in the Word document, but you do save yourself the time of manually retyping them yourself into the Word document+.

  1. Open your completed index in SKY Index. Display it in Page Ordered or As Entered order, or whatever order reflects the order in which you will carry out the embedding.
  2. Open the document that is to receive the embedded index entries in Word -- use a copy, not the original! Make sure you have the Show/Hide toolbar icon (the one with what looks like a stylized back-to front P) depressed -- each word is separated by a dot, and each paragraph ends with the back-to-front P (called a Pilcrow sign -- I learnt something new today) -- otherwise you won't be able to see your index entries.
  3. Tile SKY Index and Word side by side on your monitor's desktop. You only have to have the Main column visible in SKY Index.
  4. Embed index entries one by one:
  1.  Highlight a record by clicking on its record button.
  2.  Grab any cell (I use the Main cell) and drag it across to the Word document.
  3.  Drop the entry in the appropriate place in the Word document. If you have never embedded index entries before, you'll notice that each entry is enclosed in curly braces; it begins with "xe " (telling Word it's an index entry); the index data is enclosed in second marks (like ditto marks); and levels of subheading are separated by a colon. All elements except the braces can be edited.
  4. Exclaim in amazement and delight.
  1. To generate your index when you have finished, or if you want to check progress part way through, click the Show/Hide toolbar icon again to hide the word-space and paragraph-end symbols, otherwise the page numbers will come out all wrong.
  2. Place your cursor at the end of the document, in a new paragraph. Choose Insert > Index and Tables, and choose your options in the Index tab.
  3. Click OK.

Notes:

  • Sorting instructions: If you have used sorting overrides ("Hide Text" and/or "Ignore Text"), or if your the index is to be sorted letter-by-letter instead of word-by-word, you can ask SKY Index to include sorting instructions in each index entry that you drag into the Word document. In SKY Index choose Options > Program Options and in the Preferences tab place a checkmark beside "Include sort information when embedding". Sort information will be included in ALL entries that you drag across. You'll notice in the Word document that the sort information appears for each level of heading and subheading, from which it is separated by a semicolon.
  • Cross-references: When you drag cross-references across to Word, SKY Index automatically formats them correctly by inserting the symbol "\t". Word has no way of verifying the validity of cross-references.
  • Page spans: Word manages page spans by using what it calls "bookmarks". You can insert named markers anywhere in the text to create these bookmarks; creating page spans is only one of the number of uses that Word puts bookmarks to. When you create an index entry for a span in Word, you (1) insert a bookmark at the end of the span, (2) insert the index entry at the beginning of the span, and (3) in the index entry insert the name of the bookmark, which Word precedes by the symbol "\r". Clearly, SKY Index has no idea where the span ends, so whenever you have used a page span in an index entry, SKY inserts after the "\r" symbol the text "SKY0001". You must create a bookmark and overwrite "SKY0001" with the name of the bookmark in every case, otherwise you will get error messages when you generate the index in Word. As far as I know, there is no way to set formatting preferences for page spans (simple, aggressive or Chicago) in Word.

Character map

Unlike previous versions of SKY Index, SI8 uses the Windows provided character map. This is because of the Windows Character Map's support of Unicode characters. Rather than try to rewrite what's already been covered on the Internet, we will simply provide a link to Microsoft's description of the Character Map:

 How to Use Special Characters in Windows Documents


Acronyms

Acronyms are essentially a way for you to abbreviate lengthy headings that you know you'll encounter frequently in your current index. You can also use Acronyms for terms that you encounter frequently in all your indexes and put them in your 'default' index template so they are available for every index you do. When you type an Acronym followed by a space, the abbreviation is changed into the full text you've defined for that Acronym.

Tips

Acronyms now expand when you press any key that takes you to another cell -- enter, tab, backslash, or any of the cursor keys.

There is an Acronyms dockable toolbar along the top of the screen. To set up a single acronym, simply click the <Add/Edit Acronym> button in the toolbar, and type the acronym and its expansion in the Acronym Editor. There is no limit to the length of the expansion. You can see the Acronyms you've defined to help you remember them.

To enter several acronyms at once, or to manage your acronyms, choose Options>Data Entry>Acronyms. The acronyms and their expansions are displayed in a grid just like the data entry grid -- you can use exactly the same editing and formatting keystrokes as when you are doing data entry in the index, including Ctrl+; to append a new acronym and Ctrl+I/Ctrl+B for italics and bold. Pressing Shift+F2 with your cursor in a cell takes you to the large Text Editor, where you have the full range of options that is available when you use the Text Editor editing index records. There is no limit to the number of acronyms you can have, although only the first 40 will be displayed in the Acronym toolbar. To sort the acronyms into alphabetical order, click the Refresh button.

AutoCorrect: Are there words that you consistently mistype? If so, you can use Acronyms as an auto-correct feature. Type the misspelt versions into the Acronym textbox and the correct spelling into the Expansion textbox in the Acronyms tab of your default template. Then whenever you type a word incorrectly, SKY Index will automatically correct it for you. For example, in indexing recipe books I invariably type "prok" instead of "pork". I have set up the acronym "prok" and its expansion as "pork", so that whenever I type "prok" SKY Index automatically corrects my spelling to "pork".

If you follow an acronym with a period instead of a space, the acronym will be expanded but there will be no space after the expanded text so, for instance, if you have an acronym sl=school, you could type sl.house and have schoolhouse.

If you follow an acronym with a hyphen instead of a space, the acronym will not be expanded and the hyphen will be changed to a space.


Working in teams

When you are working in team, you can keep track of who created records and when they created them. The team leader can also edit records and record the date edited.

When you create a record, SKY Index attaches to it the initials that you typed in Program Options when you installed SI8, as well as the date you created the record, when that record is modified, the initials of the person who modified it and the date it was modified. You can view all this information by going to the View menu and choosing Creator, Edited, Date Created and Date Edited.

To retain this information when merging indexes, you must use Merge. You can't use Export and Import, because when you Export an index you lose the information about creation and editing information. The one exception is that the new IDEX (Index Data EXchange) import/export format will retain this information.


Non-standard page runs

On a couple of occasions I have had a client specify that page runs be treated in a non-standard way. On one occasion, a client didn't like the fact that "Aggressive" setting reduced 1095-1103 to 1095-103, which I had to agree looked pretty strange. Another client specified that page numbers were to be "aggressive" when only the last digit changed, but "simple" when the last two digits changed. Yikes!

Not to worry, though. You can define your own rules by choosing Options>Index>Locators and then clicking the Conflation drop-down list and choosing "<Custom>". You will then be presented with a dialog where you can create your own set of rules for page range conflation. Click the question mark at the top-right of the dialog for details on the various options available and an example.


Creating a spell check dictionary file from an index

You've just completed a huge index with heaps of specialist terms, proofread it meticulously, and delivered it. The client was so impressed they want you to do another one on the same subject. Can you face all that proofreading again?

Thankfully, you can use your earlier index to create your own dictionary of specialist terms.

The instructions below look complex, but once you've done it you'll see how easy it is.

1. CREATE A DICTIONARY FILE:

  1. Open the index and "Save As" with a new name.
  2. Open the Find/Replace dialogue box.
  3. In the Find What textbox type an asterisk. Leave Replace With blank. Place a checkmark next to Use Pattern Matching. From Field choose Page.
  4. Click Find, then Replace All.
  5. In the Index Options dialogue box select the Output Format tab.
  6. Select the "Text (ASCII)" preset.
  7. Delete everything in the boxes, including the spaces next to Sub1, Sub2, Sub3.
  8. Select the Style tab and uncheck Alphabet separators and Space before.
  9. Click OK.
  10. Print the index to Word.

2. EDIT THE DICTIONARY FILE:

  1. Open the output file in Word (it will have the extension .TXT).
  2. Open Find and Replace dialogue box.
  3. In the Find what textbox type a space.
  4. In the Replace with textbox type ^p (circumflex followed by a lower-case letter p).
  5. Click Replace All, then Cancel.

3. SORT THE DICTIONARY FILE (2 methods):

This method involves fewer operations, but if there are many duplicates you will end up with a larger and possibly slower file.

  1. Select all the text (Ctrl+A).
  2. Choose Tables > Sort, and click OK.
  3. Edit the file by removing numbers, punctuation, parentheses, quote marks etc. The Find and Replace box can help you do this quickly.
  4. Save the file and close Word.

OR

This method involves more operations, but removes duplicate terms thus reducing the file size

  1. Save the file and close Word.
  2. Open SKY (or close any index that is open).
  3. Choose File > Import.
  4. Select the text file and click Open.
  5. In the Input Field Mapping box uncheck Fields Are Enclosed In Quotes, and click OK.
  6. Either type a new name for the index, or overwrite the earlier temporary index, and click OK.
  7. Choose Tools > Remove Duplicate Records and click OK.
  8. With the index still in sorted order, edit it by removing numbers, punctuation, parentheses, quote marks etc. Use Find/Replace to help you.
  9. Set the output for Text output as above.
  10. Generate the index.

4. INSTALL THE DICTIONARY FILE:

  1. Open Windows Explorer.
  2. Replace the new dictionary name's extension .TXT with .DIC.
  3. Move the dictionary to the My Documents\SKY Index\Templates folder.
  4. In Sky Index, choose Options>Preferences>File Locations.
  5. Next to User Dictionary click the button named "Change".
  6. Select the new dictionary and click OK.

Right-clicking for the context menu

Some of SKY Index's most commonly used functions can be accessed using by clicking the mouse's right button. This saves you having to remember the keyboard shortcuts, or spending time searching menus for these commands.

Hover your mouse over one of the cells in the data entry grid and press the right mouse button. (Note that you need to be in view mode.) A special menu pops up, divided into three sections: the top one deals with cutting and pasting; the middle with duplicating; and the bottom one with moving the contents of cells. Have a look at the context menu today -- it could save you a lot of time in the future.

You can also right-click over records in the preview pane. When you do this a menu pops up with the same options, minus the cutting and pasting ones. I find this of limited value, since if there is more than one record for an entry some of the actions affect only the record with the lowest page number.

Like to keep your hands on the keyboard? If you have a Windows keyboard, you can press the Context Menu key instead -- that's the one just to the left of the right-hand Control key. The context menu that appears acts on whichever cell is highlighted in the data entry grid. To select a command, either press the up or down arrows on your keyboard, or press the key for the underlined letter.


Duplicating a heading as a subheading, or a subheading as a heading

To duplicate a subheading as a main heading:

If you type a heading followed by a subheading, you can turn that subheading into a new heading in its own right: Place the marquee over any cell and press Ctrl+F11 (Duplicate and Shift Left to Main - note that there is no menu item for this command).

 To duplicate a main heading as a subheading:

If you type a main heading, you can turn that main heading into a subheading of a new main heading: Press Ctrl+F4 (or choose Edit>Duplicate & Swap).


Capitalizing initials

SI8 the option of capitalizing initials at the formatting stage instead of at the data entry stage. I much prefer this way, because it gives me the option of changing my mind (or more likely the editor changing his/her mind) part-way through, without having to worry about the capitalization of proper names.

  1. Choose Options>Index.
  2. Click the Heading Style tab.
  3. In the row of tabs at the top make sure the tab for "Main" is selected.
  4. Near the bottom of the configuration pane, tick the "Initial Caps" option.
  5. Click Save. You'll notice that whereas the main headings in the Entry grid display exactly as you typed them, the initial letters are capitalized in the Preview pane.

But what happens when you enter cross-references? If you type a capital initial after "see" or "see also", the AutoComplete feature won't kick in, right? Wrong.

  1. Choose Options>IData Entry
  2. Click the AutoComplete tab.
  3. Click "Ignore Case" to place a tick in the checkbox.
  4. Click Save. Now when you type a capital initial after "see" or "see also", SKY Index will complete the term for you with a capital initial, whether or not you typed the original term with a capital initial.

Orphan cross-references

Many clients specify that they want "see also" cross-references to appear as subheadings, as either the first or the last. You set this option in the Cross-references tab of Index Options. In the Placement row of the See also column choose "First subheading" or "Last Subheading".

But occasionally you will want to make a "see also" cross-reference from a heading that has no subheadings. Normally it would look like this: fruit, 20-25 see also grapes

Some clients specify that if there are no subheadings attached to a heading, then the cross-reference must appear on the same line as the heading, either before the locators or after them. This may also be your preference even if a client does not specify it. For example: fruit, 20-25. See also grapes or fruit (see also grapes), 20-25

How do you do this?

At the bottom of the Cross-references tab is a section called "Merge orphans to". By default it is set at "Don't". To get the cross-references to appear "before the locators in such cases, choose "Before locators"; or to appear after the locators, choose "After locators". Enter any punctuation and/or parentheses in the "Prefix" and "Suffix" boxes below.

Using this strategy you can easily attain a format like: fruit (see also grapes), 20-25 grapes, 4-10 see also fruit green, 5 red, 7


British spelling dictionary

When you install SI8, the American spelling dictionary is selected by default. If you live in a country that does not use US spelling, you can install the UK dictionary instead.

  1. Choose Options>Preferences.
  2. Click the File Locations tab
  3. From the 'Main Dictionary' list, choose British English (or one of the other choices if you're not working with an English language.
  4. Click Save.

As well as accepting British spellings, this dictionary still accepts American spellings, so don't rely on it for an index you are converting for an overseas edition. Note also that it rejects words ending in -ise and -isation, preferred by some British publishing houses, and the norm in Australia. As it is not possible to edit the so-called "main" dictionaries, you will need to add such words to your user dictionary. (I'm not familiar with the spelling conventions in Canada and other English-speaking countries, so I can't say how well they are served.)


Using an ellipse to begin a list of locators

Those of you who are members of Index-L will have read the thread on alternatives to the comma or the space between an index heading and its locators. One of the suggested alternatives was the ellipsis. An example from a published legal index was provided:

 REMEDIES

 Failure to bargain
    Back pay...15.07[2]; 16.02[3]
    Status quo ante...15.07[3]; 16.02[3]
Strikes, illegal
    Damages...6.03[1] et seq.
    Generally...5.07
SENIORITY
    Absenteeism caused by...1.09[3]

How do you get the ellipsis character? You don't insert three dots, that's for sure -- otherwise a line break could occur between the dots, which would be most confusing.

  1. Choose Options>Index.
  2. Click the Locators tab.
  3. In the Leader textbox delete whatever is there. Holding down the Alt key, type 0133 on the numeric keypad, and release the Alt key.
  4. Click Save.

Quickly go to the target of a cross-reference

If you want to go to the target of a cross-reference, hold down the Ctrl key while you click on the cross-reference (in the page field of the grid). If the target exists, a pane will appear at the bottom of the Index Pane that will have the target highlighted. Note: That pane is editable so you can make changes to the target if you desire.


How to duplicate an entry and swap the main and subheadings (Double Posting)

In the grid

  • Duplicate all records containing the main heading by pressing (Ctrl+F8) while the grid marquee is over the main heading of any record containing the desired heading. Note: F8 is the Select Heading command and holding down the Ctrl key tells SKY Index to also duplicate the selected records.
  • Swap all selected entries by choosing Edit>Swap (F4)

In the index pane

  • Click (or navigate to) the desired main heading to select it.
  • Duplicate and Swap all selected entries by pressing (Ctrl+F4) Note: F4 is the Swap command and holding down the Ctrl key tells SKY Index to duplicate the records to be swapped prior to swapping them.

How to create main headings from the subheadings of an existing set of entries

In the grid

  • With the grid marquee over the main heading of any record in the grid with the desired main heading, Press Ctrl+F8 to select and duplicate the records for that main heading.
  • Press F11 to shift all subheadings left by one cell.

How to post all subheadings of an existing heading under a synonymous heading

In the grid

  • With the grid marquee over the desired main heading, duplicate and group the main heading by selecting Edit>Duplicate Heading (Ctrl+F8)
  • Rename the main heading of one of the duplicated records and and before pressing Enter, Tab or F2...
  • Press Ctrl+Alt+Enter to propagate the change to all other main headings with the same name.

In the index pane

  • Place the marquee over the desired main heading.
  • Choose Edit>Duplicate (Ctrl+D) to duplicate the heading. The new heading will have '_Copy' appended to the name.
  • Press F2 to edit the heading's name.

How to keep track of both subjects and authors in a combined subject/author index

Label your subject entries with one of the nine available labels. You can then use the Filter function to view only the subject entries or only the author entries as described below. A label is applied/removed by holding down the Ctrl key and pressing a numeric key 1 through 9.

To see only subject entries: Set the Filter dialog so that unfiltered records are hidden. Then check the check box to Show marked records.

To see only author entries: Set the Filter dialog so that unfiltered records are shown. Then check the check box to Hide marked records.

To see all entries: Click the Clear button on the Filter dialog.


Demoting part of a heading for multiple records (This tip was provided by Michael Wyatt)

The problem: Sometimes you will have established a compound heading in the form of a phrase, and then you find you need to split it into a heading plus subheading. How do you do this easily if you have already attached a number of locators to the heading?

The solution: Let's say you have established the heading "goals at work" and attached half a dozen page references. Now you find that "goals" have cropped up in a different context, so you want to change your earlier entries to the heading "goals" with the subheading "at work".

  • Create a group: Highlight one instance of the heading and create a group by choosing Group>Group on Main Heading or press Shift+F6.
  • In one of the records insert a comma after "goals".
  • Propagate the change: Press Ctrl+Alt+Enter, so that all the records read "goals, at work".
  • Select all the records: Press Ctrl+A or choose Edit>Select All.
  • Demote: Choose Edit>Demote or press F6.
  • When the "Select field" box pops up, choose "Main" and click OK.
  • Ungroup the records: If you grouped the records, ungroup them by Ctrl+Shift+U.

How to duplicate an index entry, swap the main and subheadings, and then combine the subheading with the main heading separated by a space

  • Select the entry by choosing Edit>Select Entry (F9)
  • Choose Edit>Duplicate & Swap (Ctrl+F4)
  • Choose Edit>Combine (F7)

How to rename a main or subheading that has many subheadings

In the grid

  • With the grid marquee over the desired heading.
  • Press F2 to enter Edit Mode.
  • Edit the heading text and then before you press Enter, Tab, or F2...
  • Press Ctrl+Alt+Enter to propagate the change to all other headings with the same name at the same level and with the same parent heading(s).

In the index pane

  • Place the marquee over the desired heading.
  • Press F2 to enter Edit Mode.
  • Edit the heading text.
  • Press F2 again to save the edit. Note: Moving to any other heading ether through a keyboard shortcut or by using the mouse will save your edit. 
Copyright ©, SKY Software. All Rights Reserved  ·  Last update: 18 Jan 2018   ·   Is there a problem with our website? Please report it to: Webmaster  ·  Every effort has been made to ensure accuracy, but we cannot be responsible for misprints.  ·  The SKY Software logo is a registered trademark of SKY Software.  ·  SKY Index is a trademark of SKY Software.  ·  Other products and companies referred to herein are trademarks or registered trademarks of their respective companies or mark holders.